logo

Could not compile stylesheet for simplistic. Using last compiled stylesheet.

Enable i2c-2

posted in Uncategorized
Tuesday, September 20 2011, 07:16 PM
admin
admin
Offline
0
Hi, who is the better way to enable i2c-2 bus connected to pins 23 and 24 at J990? I\\\'m using kernel 2.6.35.13 compiled and installed in a SD card following the tutorial: [url=http://labs.igep.es/index.php/How_to_boot_from_MicroSD_Card]http://labs.igep.es/index.php/How_to_bo ... croSD_Card[/url] I compiled X-loader from sources and mux settings at /igep-x-loader/board/igep0020/igep0020.c seems to be correct... What I\\\'ve missing? Thanks in advance!
Responses (4)
  • Accepted Answer

    Wednesday, September 21 2011, 08:50 AM - #permalink
    0
    As example you can see the arch/arm/mach-omap2/exp-igep0022.c file from your kernel sources. (igep0022_i2c2_init) Ensure that your mux is correctly configured and then call the i2c-2 register function [code] omap_register_i2c_bus(2, 400, NULL, 0); [/code] Hope it helps you
    The reply is currently minimized Show
  • Accepted Answer

    admin
    admin
    Offline
    Wednesday, September 21 2011, 11:12 AM - #permalink
    0
    First, thanks for your quick response! It\\\'s very nice when you see that you\\\'re not alone :) Your tips are very useful because they showed to me that I\\\'m on the right way. I already added that code from \\\"arch/arm/mach-omap2/exp-igep0022.c\\\" file: omap_register_i2c_bus(2, 400, NULL, 0); I added this line into \\\"static void __init igep0020_init(void)\\\" function from \\\"board-igep0020.c\\\" File, just below omap_register_i2c_bus(3, 100, igep2_i2c3_boardinfo, ARRAY_SIZE(igep2_i2c3_boardinfo)); I added Pull-up resistors too, but I still doesn\\\'t appear i2c-2 bus...I\\\'ll try to recompile kernel one more time, because just following your suggestions It should works this way
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, September 21 2011, 11:37 AM - #permalink
    0
    If you try to pass the buddy=igep0020 option in your kernel cmdline the i2c-2 bus should be initialized. As this is used on IGEPv2 expansion board.
    The reply is currently minimized Show
  • Accepted Answer

    admin
    admin
    Offline
    Wednesday, September 21 2011, 12:18 PM - #permalink
    0
    +1 This works for me! Thanks again for the support!
    The reply is currently minimized Show
Your Reply

SUPPORT


This email address is being protected from spambots. You need JavaScript enabled to view it.
This email address is being protected from spambots. You need JavaScript enabled to view it.
IGEP Community Wiki
IGEP Community Forum
IGEP Community Online Chat