logo

Could not compile stylesheet for simplistic. Using last compiled stylesheet.

microsd readonly suddently

posted in Uncategorized
Thursday, February 23 2012, 02:54 PM
0
Hi guys! I recently installed Linaro nano on microsd For some days I\\\'ve normally been using it, modifying files, etc Today It suddenly stopped saving changes When I do changes in any file (i.e. /etc/crontab) the changes has gone when restart the IGEPv2 Any help please? BR, Sergio
Responses (12)
  • Accepted Answer

    Monday, March 05 2012, 12:17 PM - #permalink
    0
    1) I\\\'ve test 10 times \\\"strace touch test.txt\\\" + \\\"reboot\\\" and 10 times the file test.txt exist! ==> works! 2) I\\\'ve run \\\"strace rm locales_4.xml\\\" + \\\"reboot\\\". When reboot is done the file locales_4.xml exist ==> doens\\\'t work correctly Attached you can find a zip file with putty.log, containing the output of the two strace commands (1,2) Also you can find syslog in the zip file attached Sergio
    The reply is currently minimized Show
  • Accepted Answer

    mcaro
    mcaro
    Offline
    Monday, March 05 2012, 10:06 AM - #permalink
    0
    When you reboot the machine the file test.txt exist ? Attach the file /var/log/syslog also ... Manel
    The reply is currently minimized Show
  • Accepted Answer

    Monday, March 05 2012, 08:10 AM - #permalink
    0
    please see it attached! sergio
    The reply is currently minimized Show
  • Accepted Answer

    mcaro
    mcaro
    Offline
    Friday, March 02 2012, 08:46 PM - #permalink
    0
    Please could you execute this command: sudo apt-get install strace strace touch test.txt and post the output for the last command Cheers Manel
    The reply is currently minimized Show
  • Accepted Answer

    Friday, March 02 2012, 12:16 PM - #permalink
    0
    Thank you Yggdrasil As soon I can I will try both (ext3 and kernel)
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, March 01 2012, 01:37 PM - #permalink
    0
    Hello, I\\\'ve got similar problems with ext4 in the linaro 12.1/12.2 releases and igep\\\'s kernel 2.6.37. I switch to ext3 to omit the problem. Edit: Passage in dmegs: [code] [ 2.268981] EXT3-fs (mmcblk0p2): error: couldn\\\'t m ount because of unsupported optional features (240) [ 2.270324] EXT2-fs (mmcblk0p2): error: couldn\\\'t m ount because of unsupported optional features [/code] Off Topic: Can you boot the linaro with the default kernel in the newer linaro images? (I.e [url=http://releases.linaro.org/12.02/ubuntu/oneiric-images/ubuntu-desktop/igep-ubuntu-desktop.img.gz]http://releases.linaro.org/12.02/ubuntu ... top.img.gz[/url] ) They failed on my board.
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, March 01 2012, 10:39 AM - #permalink
    0
    attached you can find my dmesg output. My kernel is a fresh IGEP downloaded kernel dmesg is showing this line mmc0: host does not support reading read-only switch. assuming write-enable.
    The reply is currently minimized Show
  • Accepted Answer

    Monday, February 27 2012, 01:36 PM - #permalink
    0
    Is a bit strange I don\\\'t understand why if rootfs is in rw mode you can\\\'t write or modify any file.There isn\\\'t any type of error booting ?
    The reply is currently minimized Show
  • Accepted Answer

    Friday, February 24 2012, 09:46 AM - #permalink
    0
    root@ixonplay:~# mount /dev/root on / type ext4 (rw) none on /proc type proc (rw,noexec,nosuid,nodev) none on /sys type sysfs (rw,noexec,nosuid,nodev) none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev) none on /sys/kernel/debug type debugfs (rw) none on /dev type tmpfs (rw,mode=0755) none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620) none on /dev/shm type tmpfs (rw,nosuid,nodev) none on /var/run type tmpfs (rw,nosuid,mode=0755) none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
    The reply is currently minimized Show
  • Accepted Answer

    Friday, February 24 2012, 09:41 AM - #permalink
    0
    Can you paste the output of the mount command ?
    The reply is currently minimized Show
  • Accepted Answer

    Friday, February 24 2012, 08:40 AM - #permalink
    0
    (I\\\'ve installed linaro following wiki How_to_boot_from_MicroSD_Card) ==> igep.ini ==> root=/dev/mmcblk0p2 rw rootwait dmesg shows this message: [mmc0: host does not support reading read-only switch. assuming write-enable] Quick help is wellcome
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, February 23 2012, 03:34 PM - #permalink
    0
    Is your rootfs mounting with rw permissions ?
    The reply is currently minimized Show
Your Reply

SUPPORT


This email address is being protected from spambots. You need JavaScript enabled to view it.
This email address is being protected from spambots. You need JavaScript enabled to view it.
IGEP Community Wiki
IGEP Community Forum
IGEP Community Online Chat