logo

Could not compile stylesheet for simplistic. Using last compiled stylesheet.

modify make file to use a new libary

posted in Uncategorized
Saturday, November 12 2011, 06:15 PM
0
Hello, Please help me. I hope that you answer. I want to modify make file in order to use curl library, in an application which use dsplink.I keep the skeleton of yours samples and I have put my c files and I have modified the build files in order to produce my executable. First of I use tool-chain poky-eabi-glibc-i586-arm-toolchain-sdk-3.2.1.tar.bz2. After installation the new header files are installed to /usr/local/poky/eabi-glibc/include and the the appropriate libraries to the /usr/local/poky/eabi-glibc/lib. The first problem is appeared when I type #include , I get a message that can not find this but existed. When I type full path(/usr/local/poky/eabi-glibc/include/curl/curl.h) all are ok!! I see in the makefile, in the root directory,that compiler search for include file to this path OSINC_TARGET=$(CSTOOL_DIR)/target/usr/include \\\\, but there is not folder target in the toolchain folder, which is located to usr/local/poky/eabi-glibc folder. Then in the folder myapplication/Linux/Component I put USR_LD_FLAGS := -lcurl. But that not works. Can not find the libary. I ask you because you have made all the files for build an application. It is a general question how to modify your makefile to use another library like curl or opencv. Thanks Regards Giorgos
Responses (2)
  • Accepted Answer

    mcaro
    mcaro
    Offline
    Saturday, November 12 2011, 06:48 PM - #permalink
    0
    Hi Giorgos, What Makefile are you modifying ? At end you should use the right path for include and link the libraries, I mean: If you wish include the headers (add the appropriate path) the compiler need it as: -I option, in your case: -I so, for include any library path you should use two commands: -L and -l Please attach the Makefile I guess it can be more useful for help you ... Manel
    The reply is currently minimized Show
  • Accepted Answer

    Saturday, November 12 2011, 07:36 PM - #permalink
    0
    Thanks for the answer I modified only this for link the new libary in the folder in dsplink samples gcc/samples/myapplication/Linux/components. # ============================================================================ # User specified additional command line options for the linker # ============================================================================ USR_LD_FLAGS := -lcurl //this only for linking # ========================== But I have another question. I must put the new header file and the new libraries under /usr/local/poky/eabi-glibc/arm-none-linux-gnueabi/usr/include or usr/local/poky/eabi-glibc/include Thanks Regards Giorgos
    The reply is currently minimized Show
Your Reply

SUPPORT


This email address is being protected from spambots. You need JavaScript enabled to view it.
This email address is being protected from spambots. You need JavaScript enabled to view it.
IGEP Community Wiki
IGEP Community Forum
IGEP Community Online Chat